#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\"
Local $sString = "Dasher - 18 " & @CRLF & _
"Dancer - 22" & @CRLF & _
"Prancer - 17" & @CRLF & _
"Vixen - 19" & @CRLF & _
"Comet- 28" & @CRLF & _
"Cupid - 21" & @CRLF & _
"Donder - 16" & @CRLF & _
"Rudolph - 31" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")