package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\`)
var str = `Dasher - 18
Dancer - 22
Prancer - 17
Vixen - 19
Comet- 28
Cupid - 21
Donder - 16
Rudolph - 31
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}