$re = '/\/m';
$str = 'Dasher - 18
Dancer - 22
Prancer - 17
Vixen - 19
Comet- 28
Cupid - 21
Donder - 16
Rudolph - 31
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);