using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\";
string input = @"Dasher - 18
Dancer - 22
Prancer - 17
Vixen - 19
Comet- 28
Cupid - 21
Donder - 16
Rudolph - 31
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}