package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\n|\s$)`)
var str = `★★★★★★: Nearl the Radiant Knight (Limited)
★★★★★★: Flametail / Rosmotis
★★★★★: Corroserum [limited] / Liskarm The Charging Wyvern (Limited)
★★★★★: Wild Mane
★★★★★: Honeyberry
★★★★: Pudding [limited]
★★★★★★: Nearl the Radiant Knight [Limited] / Flametail (70% in 6* Operators)
★★★★★: Corroserum (50% in 5* Operators)
★★★★★★: W [Limited] / Rosmontis [Limited] (Rate up in the rest 30% in 6* Operators)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}