import re
regex = re.compile(r"(?:\n|\s$)", flags=re.MULTILINE)
test_str = ("★★★★★★: Nearl the Radiant Knight (Limited)\n"
"★★★★★★: Flametail / Rosmotis\n"
"★★★★★: Corroserum [limited] / Liskarm The Charging Wyvern (Limited)\n"
"★★★★★: Wild Mane\n"
"★★★★★: Honeyberry\n"
"★★★★: Pudding [limited]\n"
"★★★★★★: Nearl the Radiant Knight [Limited] / Flametail (70% in 6* Operators)\n"
"★★★★★: Corroserum (50% in 5* Operators)\n"
"★★★★★★: W [Limited] / Rosmontis [Limited] (Rate up in the rest 30% in 6* Operators)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")