#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^Zn](\.\s)"
Local $sString = "aaa. Zn. bbb" & @CRLF & _
"aaa. Zn. bbb." & @CRLF & _
"aaa Zn. bbb." & @CRLF & _
"aaa Zn. bbb" & @CRLF & _
"aaa Bns. bbb" & @CRLF & _
"aaa Bns. Bbb" & @CRLF & _
"aaa Zn. Aaa Bns. Bbb" & @CRLF & _
"1" & @CRLF & _
"aaa" & @CRLF & _
"aaa." & @CRLF & _
"aaa Abbb" & @CRLF & _
"aaa. Zns. bbb" & @CRLF & _
"aaa. Zns. bbb." & @CRLF & _
"aaa Zns. bbb." & @CRLF & _
"aaa Zns. bbb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")