$re = '/[^Zn](\.\s)/m';
$str = 'aaa. Zn. bbb
aaa. Zn. bbb.
aaa Zn. bbb.
aaa Zn. bbb
aaa Bns. bbb
aaa Bns. Bbb
aaa Zn. Aaa Bns. Bbb
1
aaa
aaa.
aaa Abbb
aaa. Zns. bbb
aaa. Zns. bbb.
aaa Zns. bbb.
aaa Zns. bbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);