import Foundation
let pattern = #"[^Zn](\.\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aaa. Zn. bbb
aaa. Zn. bbb.
aaa Zn. bbb.
aaa Zn. bbb
aaa Bns. bbb
aaa Bns. Bbb
aaa Zn. Aaa Bns. Bbb
1
aaa
aaa.
aaa Abbb
aaa. Zns. bbb
aaa. Zns. bbb.
aaa Zns. bbb.
aaa Zns. bbb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)