#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[-+.\w]+\b@(?:(?!\.gov)\S)+(?!\S)"
Local $sString = "abc123@abc.c # 'o' is in 'gov' so it ends the returned string there" & @CRLF & _
"456@email.edu" & @CRLF & _
"governmentemail@governmentaddress. #'.gov' omitted" & @CRLF & _
"test@test.gov" & @CRLF & _
"test.test@test.org.gov.test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")