re = /[-+.\w]+\b@(?:(?!\.gov)\S)+(?!\S)/m
str = 'abc123@abc.c # \'o\' is in \'gov\' so it ends the returned string there
456@email.edu
governmentemail@governmentaddress. #\'.gov\' omitted
test@test.gov
test.test@test.org.gov.test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end