using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^,]*,\s*){3}(?<test>[^,]+)\s+,";
string input = @"12/11/2018 , abc , def , ced test123 , xyz";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}