package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^,]*,\s*){3}(?<test>[^,]+)\s+,`)
var str = `12/11/2018 , abc , def , ced test123 , xyz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}