re = /(?:[^,]*,\s*){3}(?<test>[^,]+)\s+,/
str = '12/11/2018 , abc , def , ced test123 , xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end