#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<JUNK>.*?)(?!\(.\))(\(.*\))?\sname\:(?P<name>\d+)\.$"
Local $sString = "ID pqr () name:123." & @CRLF & _
"" & @CRLF & _
"ID pqr (a) () name:123." & @CRLF & _
"" & @CRLF & _
"ID pqr (a) (b) () name:123." & @CRLF & _
"" & @CRLF & _
"ID pqr (a) (b) () name:123." & @CRLF & _
"" & @CRLF & _
"ID pqr (a) (b) (XX) name:123." & @CRLF & _
"" & @CRLF & _
"ID pqr (a) (b) (X) name:123." & @CRLF & _
"" & @CRLF & _
"ID pqr (aa) (b) (X) name:123." & @CRLF & _
"" & @CRLF & _
"ID pqr (a) (bb) (X) name:123." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")