import re
regex = re.compile(r"^(?P<JUNK>.*?)(?!\(.\))(\(.*\))?\sname\:(?P<name>\d+)\.$", flags=re.MULTILINE)
test_str = ("ID pqr () name:123.\n\n"
"ID pqr (a) () name:123.\n\n"
"ID pqr (a) (b) () name:123.\n\n"
"ID pqr (a) (b) () name:123.\n\n"
"ID pqr (a) (b) (XX) name:123.\n\n"
"ID pqr (a) (b) (X) name:123.\n\n"
"ID pqr (aa) (b) (X) name:123.\n\n"
"ID pqr (a) (bb) (X) name:123.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")