import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<JUNK>.*?)(?!\\(.\\))(\\(.*\\))?\\sname\\:(?P<name>\\d+)\\.$";
final String string = "ID pqr () name:123.\n\n"
+ "ID pqr (a) () name:123.\n\n"
+ "ID pqr (a) (b) () name:123.\n\n"
+ "ID pqr (a) (b) () name:123.\n\n"
+ "ID pqr (a) (b) (XX) name:123.\n\n"
+ "ID pqr (a) (b) (X) name:123.\n\n"
+ "ID pqr (aa) (b) (X) name:123.\n\n"
+ "ID pqr (a) (bb) (X) name:123.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}