# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(\d{4})(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d).*/$1:$2:$3 $4:$5:$6/;t' <<< "VID_20230718_094416.mp4"