$re = '/.*(\d{4})(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d).*/';
$str = 'VID_20230718_094416.mp4';
$subst = "$1:$2:$3 $4:$5:$6";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;