use strict;
my $str = 'VID_20230718_094416.mp4';
my $regex = qr/.*(\d{4})(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d).*/p;
my $subst = '$1:$2:$3 $4:$5:$6';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";