#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*(\d{4})(\d\d)(\d\d)_(\d\d)(\d\d)(\d\d).*"
Local $sString = "VID_20230718_094416.mp4"
Local $sSubst = "$1:$2:$3 $4:$5:$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)