using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^my-registry\/image-for-other-backends:tag.*$";
string input = @"my-registry/image-for-backend-1:tag
my-registry/image-for-other-backends:tag";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}