package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^my-registry\/image-for-other-backends:tag.*$`)
var str = `my-registry/image-for-backend-1:tag
my-registry/image-for-other-backends:tag`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}