$re = '/^my-registry\/image-for-other-backends:tag.*$/m';
$str = 'my-registry/image-for-backend-1:tag
my-registry/image-for-other-backends:tag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);