re = /^my-registry\/image-for-other-backends:tag.*$/m
str = 'my-registry/image-for-backend-1:tag
my-registry/image-for-other-backends:tag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end