using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""entry:\/\/([^_]+)_([^_]+)_([^_]+)"" title=""";
string substitution = @"<a href=""entry://$1 $2 $3"" title=""";
string input = @"<ul><li><span class=""Latn"" lang=""en""><a href=""entry://Thousand_Island_dressing"" title=""Thousand Island dressing"">Thousand Island dressing</a></span></li></ul>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}