import re
regex = re.compile(r"<a href=\"entry:\/\/([^_]+)_([^_]+)_([^_]+)\" title=\"", flags=re.MULTILINE | re.DOTALL | re.IGNORECASE)
test_str = "<ul><li><span class=\"Latn\" lang=\"en\"><a href=\"entry://Thousand_Island_dressing\" title=\"Thousand Island dressing\">Thousand Island dressing</a></span></li></ul>"
subst = "<a href=\"entry://$1 $2 $3\" title=\""
result = regex.sub(subst, test_str)
if result:
print(result)