import Foundation
let pattern = #"<a href="entry:\/\/([^_]+)_([^_]+)_([^_]+)" title=""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"<ul><li><span class="Latn" lang="en"><a href="entry://Thousand_Island_dressing" title="Thousand Island dressing">Thousand Island dressing</a></span></li></ul>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="entry://$1 $2 $3" title=""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)