use strict;
my $str = '<ul><li><span class="Latn" lang="en"><a href="entry://Thousand_Island_dressing" title="Thousand Island dressing">Thousand Island dressing</a></span></li></ul>';
my $regex = qr/<a href="entry:\/\/([^_]+)_([^_]+)_([^_]+)" title="/msip;
my $subst = '<a href="entry://$1 $2 $3" title="';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";