#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(.+-front))(.*?)-(glass|glass-.*?lcd|lcd)-.*?(replacement|repair)(.*?)"
Local $sString = "iphone-repair/iphone-4s-repair/iphone-4s-lcd-repair" & @CRLF & _
"iphone-repair/iphone-4s-repair/iphone-4s-glass-repair" & @CRLF & _
"iphone-repair/iphone-4s-repair/iphone-4s-glass-amp-lcd-replacement" & @CRLF & _
"iphone-repair/iphone-4s-repair/iphone-4s-front-glass-amp-lcd-amp-back-glass-replacement"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")