const regex = /^(?!(.+-front))(.*?)-(glass|glass-.*?lcd|lcd)-.*?(replacement|repair)(.*?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(.+-front))(.*?)-(glass|glass-.*?lcd|lcd)-.*?(replacement|repair)(.*?)', 'gm')
const str = `iphone-repair/iphone-4s-repair/iphone-4s-lcd-repair
iphone-repair/iphone-4s-repair/iphone-4s-glass-repair
iphone-repair/iphone-4s-repair/iphone-4s-glass-amp-lcd-replacement
iphone-repair/iphone-4s-repair/iphone-4s-front-glass-amp-lcd-amp-back-glass-replacement`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}