re = /^(?!(.+-front))(.*?)-(glass|glass-.*?lcd|lcd)-.*?(replacement|repair)(.*?)/m
str = 'iphone-repair/iphone-4s-repair/iphone-4s-lcd-repair
iphone-repair/iphone-4s-repair/iphone-4s-glass-repair
iphone-repair/iphone-4s-repair/iphone-4s-glass-amp-lcd-replacement
iphone-repair/iphone-4s-repair/iphone-4s-front-glass-amp-lcd-amp-back-glass-replacement'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end