# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^)(?!$)/-/gmi;t' <<< " E9:F18 M17 M17 X1:H8
F105 S34 X1:H8
F31:X1 Q1:X1 W3 "