import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^)(?!$)";
final String string = " E9:F18 M17 M17 X1:H8 \n"
+ "F105 S34 X1:H8\n"
+ "F31:X1 Q1:X1 W3 ";
final String subst = "-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}