const regex = /(?!^)(?!$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^)(?!$)', 'gmi')
const str = ` E9:F18 M17 M17 X1:H8
F105 S34 X1:H8
F31:X1 Q1:X1 W3 `;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);