re = /(?!^)(?!$)/mi
str = ' E9:F18 M17 M17 X1:H8
F105 S34 X1:H8
F31:X1 Q1:X1 W3 '
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result