#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^{]*apple[^}]*cherry[^}]*"
Local $sString = "{ apple" & @CRLF & _
"banana" & @CRLF & _
"cherry " & @CRLF & _
"}" & @CRLF & _
"{ banana" & @CRLF & _
"cherry" & @CRLF & _
"grape" & @CRLF & _
"}" & @CRLF & _
"{ cherry" & @CRLF & _
"grape" & @CRLF & _
"apple" & @CRLF & _
"orange" & @CRLF & _
"cherry" & @CRLF & _
"grape" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")