$re = '/[^{]*apple[^}]*cherry[^}]*/m';
$str = '{ apple
banana
cherry
}
{ banana
cherry
grape
}
{ cherry
grape
apple
orange
cherry
grape
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);