import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\{]*apple[^\\}]*cherry[^\\}]*";
final String string = "{ apple\n"
+ "banana\n"
+ "cherry \n"
+ "}\n"
+ "{ banana\n"
+ "cherry\n"
+ "grape\n"
+ "}\n"
+ "{ cherry\n"
+ "grape\n"
+ "apple\n"
+ "orange\n"
+ "cherry\n"
+ "grape\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}