const regex = /[^{]*apple[^}]*cherry[^}]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^{]*apple[^}]*cherry[^}]*', 'gm')
const str = `{ apple
banana
cherry
}
{ banana
cherry
grape
}
{ cherry
grape
apple
orange
cherry
grape
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}