#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\d\d:){2}\d\d,\d\d\d| --> )+(?=(?:$\n.+)+chemical)"
Local $sString = ""1" & @CRLF & _
"00:01:46,356 --> 00:01:49,893" & @CRLF & _
"What is this? It's blue." & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:01:50,794 --> 00:01:54,998" & @CRLF & _
"We used a different chemical process," & @CRLF & _
"but it is every bit as pure." & @CRLF & _
"" & @CRLF & _
"3" & @CRLF & _
"00:01:55,199 --> 00:01:58,267" & @CRLF & _
"It may be blue, but it's the bomb.""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")