use strict;
my $str = '"1
00:01:46,356 --> 00:01:49,893
What is this? It\'s blue.
2
00:01:50,794 --> 00:01:54,998
We used a different chemical process,
but it is every bit as pure.
3
00:01:55,199 --> 00:01:58,267
It may be blue, but it\'s the bomb."';
my $regex = qr/((\d\d:){2}\d\d,\d\d\d| --> )+(?=(?:$\n.+)+chemical)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}