const regex = /((\d\d:){2}\d\d,\d\d\d| --> )+(?=(?:$\n.+)+chemical)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d\\d:){2}\\d\\d,\\d\\d\\d| --> )+(?=(?:$\\n.+)+chemical)', 'gm')
const str = `"1
00:01:46,356 --> 00:01:49,893
What is this? It's blue.
2
00:01:50,794 --> 00:01:54,998
We used a different chemical process,
but it is every bit as pure.
3
00:01:55,199 --> 00:01:58,267
It may be blue, but it's the bomb."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}