import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d\\d:){2}\\d\\d,\\d\\d\\d| --> )+(?=(?:$\\n.+)+chemical)";
final String string = "\"1\n"
+ "00:01:46,356 --> 00:01:49,893\n"
+ "What is this? It's blue.\n\n"
+ "2\n"
+ "00:01:50,794 --> 00:01:54,998\n"
+ "We used a different chemical process,\n"
+ "but it is every bit as pure.\n\n"
+ "3\n"
+ "00:01:55,199 --> 00:01:58,267\n"
+ "It may be blue, but it's the bomb.\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}