#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*[bB]ol($|[\. ].*com|com)"
Local $sString = "bol" & @CRLF & _
"bol.com" & @CRLF & _
"bol com" & @CRLF & _
" bol" & @CRLF & _
"bol.com" & @CRLF & _
"Bol" & @CRLF & _
"bolia" & @CRLF & _
"Bolle" & @CRLF & _
"bolcom" & @CRLF & _
"abole" & @CRLF & _
"lka bol.ckom sad" & @CRLF & _
"asldk bol com aosdk" & @CRLF & _
"asdlk bol.com oasdk" & @CRLF & _
"bol.com asd" & @CRLF & _
"bolle.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")