$re = '/.*[bB]ol($|[\. ].*com|com)/m';
$str = 'bol
bol.com
bol com
bol
bol.com
Bol
bolia
Bolle
bolcom
abole
lka bol.ckom sad
asldk bol com aosdk
asdlk bol.com oasdk
bol.com asd
bolle.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);