// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*[bB]ol($|[\. ].*com|com)").unwrap();
let string = "bol
bol.com
bol com
bol
bol.com
Bol
bolia
Bolle
bolcom
abole
lka bol.ckom sad
asldk bol com aosdk
asdlk bol.com oasdk
bol.com asd
bolle.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}