import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[bB]ol($|[\\. ].*com|com)";
final String string = "bol\n"
+ "bol.com\n"
+ "bol com\n"
+ " bol\n"
+ "bol.com\n"
+ "Bol\n"
+ "bolia\n"
+ "Bolle\n"
+ "bolcom\n"
+ "abole\n"
+ "lka bol.ckom sad\n"
+ "asldk bol com aosdk\n"
+ "asdlk bol.com oasdk\n"
+ "bol.com asd\n"
+ "bolle.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}