using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<drupal-entity[^>]+></drupal-entity><p> </p>";
string input = @"</p><drupal-entity data-view-mode=""oembed_display""></drupal-entity><p><strong>Designer Crush:</strong></p><drupal-entity data-view-mode=""oembed_display""></drupal-entity><p> </p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}