package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<drupal-entity[^>]+></drupal-entity><p> </p>`)
var str = `</p><drupal-entity data-view-mode="oembed_display"></drupal-entity><p><strong>Designer Crush:</strong></p><drupal-entity data-view-mode="oembed_display"></drupal-entity><p> </p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}